MobiSystems

グラフの追加、並べ替え、フィルター

このガイドでは、データをグラフ化する方法、データを並べ替える方法、必要な行だけを表示するようにフィルターをかける方法を説明します。これにより、大規模なデータセットでもトレンドをすばやく把握し、必要な値をすぐに見つけられるようになります。グラフ作成、並べ替え、フィルター機能は、列にラベルが付いていると最も効果的に機能するため、明確な列ヘッダーがあるスプレッドシートを使用することをおすすめします。手順はWindowsから始まり、その後にMac、Android、iOS向けの手順を簡単に説明します。

始める前に

以下が準備されていることをご確認ください。

  • デバイスにMobiOfficeがインストールされていること。詳細は「複数のデバイスへのMobiOfficeのインストール」をご覧ください。

  • MobiSheetsでデータを含むスプレッドシートが開いていること。詳細は「スプレッドシートの作成と編集」をご覧ください。

  • MobiSheetsにサインインしていること。詳細は「MobiSheetsへのサインイン」をご覧ください。

  • クラウドに保存する場合は、インターネットに接続されていること。

Windowsでグラフを追加する

1. 列見出しを含め、グラフにするセル範囲を選択します。

2. リボンにある[グラフ]をクリックします。または、ドロップダウンメニューから[挿入]タブを開き、[グラフ]をクリックすることもできます。

グラフの追加、並べ替え、フィルター

3. 縦棒、折れ線、円などのグラフの種類を選択します。

4. 用意されているオプションを使ってグラフをカスタマイズし、シート上でサイズ変更や移動を行います。さらに詳細なオプションを設定するには、グラフを右クリックしてコンテキストメニューから[グラフエリアの書式設定]を選択します。

ヒント:データに合ったグラフの種類を選びましょう。値の比較には縦棒グラフや横棒グラフ、時系列の変化を示すには折れ線グラフ、全体における割合を示すには円グラフがおすすめです。

データの並べ替え

並べ替えを使うと、A から Z や最小から最大など、1 つ以上の列の値に基づいて行の順序を変更できます。

1. 並べ替えの基準にする列のセルを選択するか、範囲全体を選択します。

2. ドロップダウンメニューからデータタブを開きます。

3. 並べ替え方法を選択します:

  • 昇順で並べ替えるにはAからZ、または

  • 降順で並べ替えるにはZからAを選択します。

4. 複数の列を基準に並べ替えるには、カスタム並べ替えを選択して条件を設定します。

グラフの追加、並べ替え、フィルター

注意:MobiSheetsが列名で並べ替えを行い、ヘッダーを元の位置に保持できるよう、データにヘッダー行を含めてください。

データを絞り込み

フィルター機能を使うと、データを削除することなく、不要な行を非表示にして特定の値だけに集中できます。

1. データ範囲内のセルを選択します。

2. リボンメニューの[並べ替えとフィルター]をクリックします。または、ドロップダウンメニューから[データ]タブを開き、[フィルター]をクリックすることもできます。

グラフの追加、並べ替え、フィルター

3. 各列の見出しに小さなフィルターの矢印が表示されます。

4. フィルターを適用したい列のフィルターの矢印をクリックします。

グラフの追加、並べ替え、フィルター

5. 表示する内容の選択:

  • 特定の値のチェックボックスをオンまたはオフにして、必要な行のみを表示する、または

  • 等しい、含む、で始まるなどのテキストフィルターを使用して、独自の条件を設定します。

6. OKをクリックします。

すべての行を再表示するには、フィルターの矢印を開いてフィルターをクリアするか、「データ」タブの「フィルター」をクリックしてフィルターをオフにします。

Macでのグラフ作成、並べ替え、フィルター

1. MobiSheetsでスプレッドシートを開きます。

2. グラフを追加するには、データを選択し、「挿入」タブを開いて「グラフ」を選択します。

3. 並べ替えやフィルターを適用するには、データを選択し、「データ」タブを開いて「並べ替え」または「フィルター」を選択します。

AndroidとiOSでのグラフ作成、並べ替え、フィルター機能

スマートフォンやタブレットでは、MobiSheetsはMobiOfficeアプリに含まれています。

1. MobiOfficeアプリでスプレッドシートを開きます。

2. セルをタップしてハンドルをドラッグし、使用するデータを選択します。

3. グラフを追加するには、挿入をタップし、グラフをタップして種類を選択します。

4. 並べ替えやフィルターを適用するには、ホームをタップしてデータを選択し、並べ替えまたはフィルターを選択します。

トラブルシューティング

  • グラフが空になっている、または正しく表示されない。グラフを挿入する前に、ヘッダーを含むデータ範囲が選択されているか確認してください。また、セルにテキストではなく数値が入っていることを確認してください。

  • 並べ替えを行ったら行がバラバラになった。各行がバラバラにならないよう、1つの列だけでなくデータ範囲全体を選択してから並べ替えを行ってください。並べ替えを元に戻すには、元に戻す(Ctrl+Z)を使用します。

  • ヘッダーまでデータと一緒に並べ替えられてしまった。MobiSheetsでヘッダーを常に最上部に表示させるには、選択範囲にヘッダー行を含めてください。

  • フィルターを適用したら必要な行が表示されなくなった。フィルターは行を非表示にするだけで、削除はしません。すべての行を再表示するには、フィルターをクリアするか、フィルターをオフにしてください。

次のステップ

MobiSheets
今すぐ購入
無料ダウンロード